10
2011-07

火狐扩展升级跟不上火狐浏览器升级的速度怎么办?

作者:linker 分类: 火狐问答 浏览:    评论人数0人 【我来说两句】

    据统计,85%的火狐用户都至少安装了一个扩展。火狐上功能各异的扩展是广大用户选择Firefox的一个重要理由。而快速发布升级使得扩展作者由之前的十几个月更新一次代码变为每三个月更新一次代码,也需要相应加快其扩展更新频率。针对大家非常关心的扩展升级问题,这里给大家三点小提示,帮助你的扩展尽快跟上Firefox升级的脚步。

    一、直接使用Firefox的自动更新扩展功能

    火狐浏览器支持自动更新扩展,用户在更新Firefox版本后,第一次启动时将会自动检测所有已经安装的扩展(包括启动的和禁用的),用户将会在扩展管理器中看到每个扩展的状态。如下图,Sinafox就被显示为不兼容Firefox 5.0。同时,为了Firefox最新版的正常运行,系统会自动禁用这些不兼容的扩展。

使用火狐有讲究 Firefox扩展升级提示

     另外,用户可以自己来定义手动还是自动来检查扩展的更新。点击右上方的齿轮按钮即可进行设置。

使用火狐有讲究 Firefox扩展升级提示

    二、在火狐官方扩展中心上下载最新版本的扩展

    用户需要下载新的扩展时,可以进入火狐官方扩展中心addons.mozilla.org我们打开一个扩展,就可以看到它所支持的火狐版本。

使用火狐有讲究 Firefox扩展升级提示

    另外,所有兼容Firefox 5.0版本的扩展都在火狐扩展中心里有详细列出,大家可以去这里找支持最新版Firefox的扩展应用。据了解,现在Mozilla Firefox 扩展应用审核团队正在将那些没有及时升级的扩展重新通过程序来进行审核,并将那些不需要改动程序接口等重大功能的扩展自动升级支持最新版的Firefox。

利用工具检查扩展最新升级

    三、利用Add-on Compatibility Reporter升级扩展的版本号

    据了解,除了Firefox大版本的升级(类似从3.6升级到4.0)会更改Javascript引擎、接口等,其他版本升级对扩展的影响并不是非常大。换句话说,很多情况下,火狐浏览器和扩展并不是真正的不兼容,只是版本号没有跟上而已。而解决这个版本号问题,这里向大家推荐一个Add-on Compatibility Reporter扩展。

    这里以很多朋友都很喜欢的Sinafox新浪微博应用扩展为例,为大家演示一下如何使用这个扩展来升级版本号,使其兼容最新版的Firefox。

    升级我的火狐到Firefox 5.0后,扩展管理器提示Sinafox不兼容Firefox 5.0,如下图:

使用火狐有讲究 Firefox扩展升级提示

    同时,在火狐扩展官方网站上查看了一下,也提示该扩展不兼容5.0。

使用火狐有讲究 Firefox扩展升级提示

    为了解决这个问题,我们首先安装Add-on Compatibility Reporter扩展,在扩展中心能搜索到。

    安装后,重启Firefox火狐浏览器,在扩展管理器中将会增加一个Compatibility的按钮。点击该按钮请用户选择这个扩展是否可以继续在新版本中使用。这里我们选择“This add-on still works”。

使用火狐有讲究 Firefox扩展升级提示

    这时,该扩展会弹出一个对话框,请用户提交报告。

使用火狐有讲究 Firefox扩展升级提示

    点击提交后,会提示用户重启Firefox,这时Sinafox就可以在Firefox 5.0下使用了。

    值得提醒大家的是,这个扩展只能解决仅仅这些因为版本号导致扩展升级不能使用的问题。对于那些需要更改接口或者功能的扩展应用,并不适用,大家只可以使用这个扩展来进行尝试升级。因此,这个方法更加适用于那些依赖扩展而又非常希望在第一时间内去使用新版Firefox的朋友们。手懒的朋友们还是直接去Firefox官方扩展中心去下载升级好的扩展吧。

    最后想和大家补充一点,从Firefox的全球官方网站上发现,其已经不再以版本号明确区分Firefox版本。但是,用户仍可以自己选择是否更新到最新版的Firefox。在这一点上,Firefox一如既往给用户提供尽可能多的选择。

原创文章请注明转载自火狐插件,本文地址:http://www.firefoxplug.cn/archives/1206.html

已有0位网友发表了看法,你呢?

« 上一篇下一篇 »

评论列表:

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。